雑種のポメラニアン

フリープログラマーの日記とか人生観とか綴るよ

LazarusにGLSceneをインストール

これは厄介だった。
まずfpcの仕様が変わったのだが
GLSceneの修正が追いついてない。
stdcallを{$IF (not defined(WINDOWS)) AND (FPC_FULLVERSION>=20501)}cdecl{$ELSE}stdcall{$IFEND}
に置き換えないといけないらしい。出典
次は出展が見当たらないのだが、
constでエラーが出るところも同様にWindows以外ではconstrefにするようにする。
あと、ライブラリ類のインストールが必要。
OpenGLの類とこちらを参考にインストールした。
しかしGLSceneが根本的に大幅バージョンアップしたらしい。
調査開始!