雑種のポメラニアン

フリープログラマーの日記とか人生観とか綴るよ

Ubuntu11.04にRails3をインストール

Rails3をインストールする時は
毎回同じところで悩んでるような、毎回解決方法が違うような・・・

ちゃんとメモらないとダメだな。

http://cicolin.blogspot.com/2010/10/how-to-install-ruby-rails-and.html
build-essentialを忘れがち。

http://mitukiii.jp/2010/11/23/ubuntu10-10-ruby1-9-1-passenger3-0-rails3-0-3-install/
今まで意識してなかったけど、これも重要かも。

$ ln -s /usr/bin/gem1.9.1 /usr/bin/gem

もしかすると違うかもしれないけど
「 File not found: lib」に悩まされたら
http://railsforum.com/viewtopic.php?id=41111

sudo gem install rdoc-data
sudo rdoc-data --install
sudo gem rdoc --all --overwrite

が役に立つかも?

不本意ながらrvmを使って、やっとこさRails3がインストールできた。
rvmを使わずに普通にgemをインストールするとバージョンが1.3.7なのだが
rvmでgemをインストールすると1.6.2になる。
ちょっとバージョン違いすぎない???