雑種のポメラニアン

フリープログラマーの日記とか人生観とか綴るよ

自分用メモ

rvmを使わないでruby1.8と1.9を共存させる

  • 1.8.7のrubyを/usr/local/bin/ruby1.8としてmake
  • gemファイルの頭を「#!/usr/local/bin/ruby1.8」に修正しgem1.8としてコピー
  • rails2のプロジェクトをbundleするときは「ruby1.8 /usr/local/bin/bundle」とする
  • rails2のプロジェクトを実行するときは「ruby1.8 script/server」とする

普通はrvm使って下さい。